Home > compiz, Linux, problemi > Problemi con compiz e totem…

Problemi con compiz e totem…

luglio 2, 2007

totem_logo.png

Tempo fa, per motivi ancora inspiegati, alcuni miei colleghi decisero di passare da windows a linux. La notizia fu accolta da noi linuxiani già da molto tempo, con grandi acclamazioni e canti di gioia.

Quale distribuzione fu scelta Ubuntu 7.04. Da quando è stata presa quella decisione io mi son sempre prodigato per non far sentire la nostalgia di windows e per dimostrare che anche su linux si possono fare le stesse medesime cose che su windows (spesso anche meglio).

Ma come si suol dire.. non tutte le ciambelle escono con il buco e qualche problemino ogni tanto spunta.

Per rendere il pinguino piu’ accattivante (perchè anche l’occhio vuole la sua parte) ho fatto installare ai miei colleghi compiz-fusion. Stamane un mio collega mi chiama, lamentando un problema con totem. In pratica ogni qual volta vedesse un video o anche i semplici effetti grafici che totem mostra durante la riproduzione di un brano, l’area dell’immagine rimaneva sempre in primo piano, nonostante altre finestre fossero sopra e non era possibile nemmeno selezionare le voci del menu perchè veniavano sovrascritte sempre dall’area grafica.

Per tutti coloro che avessero tale problema, scrivo questo post, così che possano risolverlo in un batter d’occhio.

Il problema è dovuto al plugin di output usato da totem per mostrare video e effetti. Se usate totem-gstreamer (nella maggior parte dei casi starete usando questo), per risolvere il problema dovete semplicemente aprire una console e digitare:

gstreamer-properties

Verrà invocata una applicazione che permette di configurare i parametri per gstreamer. Selezionate il tab contradistinto dall’etichetta “Video” e nella sezione dei plugin di output selezionate “X Window System (No XV)”. Chiudete la finestra, provate a riapriare totem et voilà!

..anche questa volta non ho perso la faccia con i colleghi🙂

Daniele

Categorie:compiz, Linux, problemi
  1. SotoStres
    ottobre 5, 2007 alle 12:49 am

    Sei un grande!Grazie 1000.

  2. ottobre 5, 2007 alle 7:55 am

    @SotoStres
    Grazie mille .. i complimenti fanno sempre piacere (anche se non meritati)🙂

  3. virus
    novembre 1, 2007 alle 10:30 pm

    Ciao, disabilitare XV attribuisci tutti il carico dell’elaborazione video al processore, non so fino a che punto sia una buona idea…?
    Personalmente avevo risolto con totem-xine al posto di totem-gstreamer.
    Ciao

  4. novembre 2, 2007 alle 10:15 am

    @Virus
    Non ho effettuato dei test approfonditi ma “ad occhio” io non ho notato nessun calo di performance.

  5. Pix
    novembre 2, 2007 alle 4:04 pm

    Ho provato, ma la cpu passa dall’11% al 90%😦

  6. heretic
    novembre 20, 2007 alle 1:17 am

    senza contare …se non sbaglio e non si ha nemmeno piu l’anti aliasing e quindi un po piu di cubettini nei filmati …
    io sto ancora imoazzando dietro a sta cosa … come anche al v.sync che non v-synca

  1. No trackbacks yet.
I commenti sono chiusi.
%d blogger cliccano Mi Piace per questo: