Home > guide, Linux, VirtualBox, virtualizzazione > Risolvere i problemi tra VirtualBox e l’USB

Risolvere i problemi tra VirtualBox e l’USB

luglio 30, 2007

vbox_logo2_gradient.png

Tutti voi conoscete VirtualBox, nell’ambito della virtualizzazione è tra i miei prediletti ma, spesso anche le persone a cui vogliamo più bene ci fanno tribolare,no?

Tra le molte caratteristiche di questo bel progetto vi è la possibilità di montare “a caldo” dei dispositivi usb nella macchina virtuale in modo da poter utilizzare tale hardware nel sistema virtuale.Bene, molti di voi, se provano a fare ciò ricevono un bel errore Not permitted to open the USB device“.Non vi scoraggiate è facile da risolvere:Aprite il file /etc/fstab con questo comando:

sudo gedit /etc/fstab

e alla fine del file aggiungete questa riga:

none /proc/bus/usb usbfs devgid=46,devmode=664 0 0

Salvate e chiudete il file.Ora se non volete far ripartire il computer basta che digitiate

sudo mount -a

..e ora divertitevi ad usare i vostri dispositivi USB dentro VirtualBox…

Daniele

  1. ale
    settembre 12, 2007 alle 6:39 pm

    soddisfazione massima!
    grazie

  2. settembre 12, 2007 alle 7:19 pm

    @ale
    Prego.. mi fa piacere che questo mio piccolo spazio possa essere utile a qualcuno ogni tanto..grazie a te

  3. settembre 18, 2007 alle 7:56 am

    dopo averti fatto notare sul blog di telperion le problematiche di virtualbox con l’usb e certoche mi darai una risposta congrua alle mie aspettative ti chiedo:
    è possibile far funzionare la porta com1 con virtualbox?a me come al solito non va….
    grazie.
    marcos

  4. Paolo
    settembre 19, 2007 alle 9:52 am

    Grazie mille Daniele, mi sei stato di grande aiuto.

  5. settembre 24, 2007 alle 3:20 pm

    @marcos
    Scusa se ti rispondo solo ora ma ero in ferie e sono tornato oggi. Purtroppo non ho la seriale nel mio computer e quindi non posso provare. Che genere di problema riscontri? ti da un errore virtualbox o semplicemente non funziona?

    @Paolo
    E’ un piacere🙂

  6. lorenzo
    settembre 30, 2007 alle 1:55 pm

    Grazie a questo piccolo spazio anch’io ho superato uno scoglio ! Quindi grazie a te.

  7. settembre 30, 2007 alle 8:43 pm

    @lorenzo
    Questi commenti son quelli che mi spingono sempre di piu’ a tenere aggiornato questo blog..grazie

  8. Flavio
    ottobre 4, 2007 alle 1:45 pm

    Ciao!! Uso Ubuntu feisty, e virtualizzo win xp per far girare activesync ed installare programmi sul palmare…(wine non ce la fa). Purtroppo winxp mi da questo errore “Impossibile avviare la periferica. (Codice 10)” quando collego il palmare…può essere che quella riga che ho aggiunto ad fstab come hai suggerito, non funzioni per tutte le periferiche?senno, cosa ho sbagliato?😦
    Grazie mille! E compimenti per il blog!

  9. ottobre 4, 2007 alle 1:55 pm

    @Flavio
    Ciao a te🙂 Posso parlare per la mia esperienza personale. Io sono riuscito a collegare penne usb, stampanti e scanner (che addirittura linux nemmeno mi vedeva perchè non aveva i driver) senza avere il minimo problema. Mi sembra strano che un palmare usb non venga supportato perchè a quel punto è proprio windows che riconosce l’hardware. Spero ci sia qualche altro lettore di questo blog che, avendo provanto con un palmare, posso raccontarci la sua esperienza. Ciao ciao. Daniele

  10. Diego
    ottobre 4, 2007 alle 2:24 pm

    Ciao,
    non so perchè ma a me non funziona. Uso Fedora 7 (sempre aggiornata) ma l’USB con VirtualBox 1.5 non và. Mi riconosce cosa è collegato alle porte, ma poi nella VM non le collega. Ho seguito i tuoi consigli ma senza risultato. Dove sbaglio?

  11. ottobre 4, 2007 alle 2:28 pm

    @Diego
    Sicuro di aver seguito tutti i passi? Hai provato magari a fare reboot? Che errore ottieni? Io lo ho provato con la Ubuntu ma non dovrebbero esserci problemi anche con altre distribuzioni.

  12. Diego
    ottobre 4, 2007 alle 2:39 pm

    Ho anche riavviato la macchina. E questo è quello che mi da sul terminale:

    [diego@aldebaran ~]$ VBoxManage list usbhost
    VirtualBox Command Line Management Interface Version 1.5.0
    (C) 2005-2007 innotek GmbH
    All rights reserved.

    Host USB Devices:

    UUID: 7ea30512-d7f0-4026-06a9-ae7eecbf28a9
    VendorId: 0x046d (046D)
    ProductId: 0x0896 (0896)
    Revision: 1.0 (0100)
    Manufacturer: OEM
    Product: Camera
    Address: /proc/bus/usb/005/002
    Current State: Unavailable

    UUID: 367735fb-3111-4c2d-6a9b-5f030f1eb24e
    VendorId: 0x06a2 (06A2)
    ProductId: 0x0033 (0033)
    Revision: 1.0 (0100)
    Manufacturer: Topro
    Product: USB Mouse
    Address: /proc/bus/usb/004/002
    Current State: Unavailable

    UUID: c38342cb-8e9a-4798-8c8a-3fa71cfd6e34
    VendorId: 0x04b8 (04B8)
    ProductId: 0x0818 (0818)
    Revision: 1.0 (0100)
    Manufacturer: EPSON
    Product: USB MFP
    SerialNumber: LG3040605191145100
    Address: /proc/bus/usb/001/003
    Current State: Unavailable

  13. ottobre 4, 2007 alle 2:50 pm

    @Diego
    Mi spiace davvero non sò come aiutarti. Al limite per vedere se è un problema di permessi puoi provare GIUSTO PER TEST a lanciare VirtualBox con l’utente ROOT..

  14. Flavio
    ottobre 4, 2007 alle 8:26 pm

    Ciao!! Ho risolto il problema ora funziona tutto!! Colpa mia, che usavo VirtualBox da Root, mentre fstab veniva caricato dall’utente principale..insomma un po un casino però ho aggiunto il mio nome nel gruppo vboxusers, ho reinstallato tutto e adesso le usb vanno alla grande!!!
    Grazie di nuovo!

  15. Flavio
    ottobre 4, 2007 alle 8:55 pm

    Dicevo..ho risolto nel senso che le porte usb funzionano…tutto tranne il palmare(ipaq 1950)!!! Nn so io che ha…mi sa che mi toccherà creare una partizione cn windows se voglio usarlo..una bella seccatura!!

  16. ottobre 5, 2007 alle 7:58 am

    @Flavio
    Son felice che tu almeno parzialmente abbia risolto. Ma non è che il problema dipenda dal fatto che linux ti blocchi il palmare? Immagino te lo veda come un dispositivo di massa, hai provato a smontare il device lasciandolo attaccato all’usb e poi avviare VirtualBox?

  17. Flavio
    ottobre 5, 2007 alle 2:35 pm

    Purtroppo il palmare non viene visto come dispositivo di massa…viene visto piuttosto come scheda di rete esterna…ho letto su internet di tanti utenti di Ubuntu che usano l’ipaq virtualizzando windows xp su vmware…non vorrei che sia un problema di virtualbox…io faro un tentativo cn vmware e poi si vedrà..grazie mille!

  18. Flavio
    ottobre 5, 2007 alle 7:52 pm

    Vmware da lo stesso errore…è linux che blocca il palmare…:( può essere che debba rimuovere dei moduli dal kernel? come si fa a vedere i moduli caricati?

  19. ottobre 5, 2007 alle 8:24 pm

    @Flavio
    E’ come pensavo..è linux che sta usando quella risorsa quindi è bloccata. Comunque per vedere i moduli del kernel da console puoi usare lsmod

  20. Flavio
    ottobre 5, 2007 alle 9:58 pm

    Leggendo qua e la mi consigliavano di rimuovere il modulo “ipaq”…ma ho scoperto che questo non viene caricato! Probabilmente ce ne dev’essere un’altro…sai se è possibile vedere quali moduli carica una singola periferica usb? Insomma se c’è un modo per sapere come si chiama questo modulo!!🙂

  21. ottobre 6, 2007 alle 10:43 am

    @Flavio
    Prova ad aprire una console e digitare “tail -f /var/log/messages”, infila il palmare nella porta usb e guarda che messaggi vengono scritti nella console.

  22. Flavio
    ottobre 7, 2007 alle 8:10 pm

    Oct 7 21:10:02 acer kernel: [ 2251.360000] usb 4-2: new full speed USB device using uhci_hcd and address 3

    Oct 7 21:10:02 acer kernel: [ 2251.548000] usb 4-2: configuration #1 chosen from 1 choice

    ecco tutto!! Grazie mille per il tuo aiuto!

  23. vitorach
    ottobre 10, 2007 alle 4:49 pm

    è da giorni che invano cerco una soluzione riguardo la usb della mia stampante canon pixma mp180 (installata su Xp virtualizzato su virtualbox e montato su ubuntu feisty). Quella da te proposta è stata senza dubbio la + veloce ed efficace. con tale soluzione sono riuscito anche ad evitare il problema dei driver della mp180, che per linux non ci sono (eccetto turboprint). grazie e complimenti

  24. ottobre 10, 2007 alle 10:04 pm

    @vitorach
    Grazie mille! Sono contento di averti aiutato…

  25. Fabio
    ottobre 28, 2007 alle 10:45 am

    Provato con Ubuntu 7.10 e funziona alla grande , meglio del wiki di Ubuntu che tra l’altro non mi funzionava.
    Grazie Daniele !!

  26. ottobre 28, 2007 alle 4:36 pm

    e di cosa Fabio?🙂 E’ un piacere.

  27. ottobre 29, 2007 alle 3:05 pm

    Bravo bravo bravo.🙂

  28. ottobre 29, 2007 alle 3:11 pm

    Grazie Lazza.. e complimenti per il tuo blog che seguo 😛

  29. ottobre 29, 2007 alle 3:58 pm

    Ah sì? Caspio, non lo sapevo.😀

  30. ottobre 30, 2007 alle 12:22 pm

    Ciao e mi complimento con te per l’ottimo lavoro che svolgi. Sto andando di google e non so se mi trovo all’ultimo post in merito ma il mio problema e’ molto semplice. vedo un mucchio di risposte in merito al problema USB ma tutti parlano di virtualizzazione di una macchina xNIX avendo come macchina host su sistema Win, la mia necessita’ e’ diametralmente opposta. Il mio sistema host ha come SO una Debian GNU/Linux SID quello che mi interesserebbe sapere e’ come impostare la rilevazione USB sulla machina guest (Win XP).
    Grazie della collaborazione.

  31. ottobre 30, 2007 alle 1:53 pm

    @The [SKiD]
    Giusto per chiarezza:
    Macchina Host: E’ la macchina REALE. Quindi quella con il sistema operativo installato fisicamente (quindi nel tuo caso dovrebbe essere Windows da quello che ho capito)
    Macchina Guest: E’ la macchina VIRTUALE.Quella installata dentro la macchina Host (nel tuo caso quindi dovrebbe essere debian).
    Detto questo.. sinceramente non mi è mai capitato di dover installare un linux dentro windows. Che problema ti dà? Hai dei messaggi di errore particolari?

  32. ottobre 31, 2007 alle 2:32 pm

    Salve a tutti,da UBUNTU 7.10 Non riesco a far partire la mia Vbox 1.5 (con macchina virtuale winxp) con il supporto USB neppure avendo modificato fstab..
    Avevo già installato win xp come macchina virtuale prima di accorgermi che non funziona nessuna periferica usb che ho ataccato (infatti in gestione periferiche di winzoz non mi rileva neppure il controller usb) qlk dritta??
    grazie e complimenti per il Blog!

  33. ottobre 31, 2007 alle 3:00 pm

    @Marco
    Ma hai attivato le porte usb per la macchina virtuale? devi andare nelle preferenze della macchina virtuale e spuntare la voce relativa alle porte usb.

  34. novembre 5, 2007 alle 12:54 pm

    scusate per il ritardo nel rispondere, il supporto usb non ce l’ho nelle preferenze……. :((( non esiste la voce usb da nessuna parte, come mai? ho fatto qlk cappella io???
    ho anche iserito la riga :
    none /proc/bus/usb usbfs devgid=46,devmode=664 0 0
    in /etc/fstab

  35. novembre 5, 2007 alle 2:19 pm

    @Marco
    Mi sembra troppo strano.
    – Avvia VirtualBox
    – Seleziona dall’elenco la macchina virtuale che ti interessa
    – Premi il bottone Settings (se è in italiano penso sia impostazioni).
    – Vedrai che si aprirà una finestra con a destra un albero con un sacco di cose. Tra le voci trovi USB.
    – Clicca su USB e poi spunta il tick per attivare l’usb.

  36. novembre 5, 2007 alle 5:25 pm

    giuro…se mi spieghi come postare uno screenshot su questo blog te lo inoltro…

  37. novembre 5, 2007 alle 5:37 pm

    mi sono iscritto al blog, devo loggarmi su wp x postarti uno screenshoot?

  38. novembre 5, 2007 alle 6:07 pm

    ho risolto….avevo installato la versione virtualbox-ose che non è completa…infatti mancava proprio la gestione del USB

    Grazie lo stesso, questo blog si è rivelato cmq molto utile

    Marco

  39. novembre 5, 2007 alle 10:15 pm

    @marco
    Son contento che abbia risolto. Non avevo letto il tuo commento sugli screenshot, se vuoi mandarmi qualcosa puoi usare la mia email danielepiras80TOGLIMI@tiscali.it (togli TOGLIMI)

  40. novembre 6, 2007 alle 10:45 am

    ok grazie mille! ho avuto modo di gironzolare su questo blog e devo ammettere che è molto ricco di contenuti interessanti ed utili x il LINUX managment. Rinnovo i complimenti!

  41. roberto
    dicembre 5, 2007 alle 11:53 am

    ottimo

    mi ha risolto anche me il problema di non vedere le porte usb su virtualbox nonostante fossero condivise. In pratica Ubuntu non le “mollava”.. !

  42. alessiol78
    gennaio 23, 2008 alle 9:06 am

    Ciao a tutti, io invece ho installato VirtualBox su FC6 attraverso yum. La vm creata per WinXp mi vede il controller USB, ma quando attacco qlc sulla porta usb e metto la spunta nella vm per farla vedere a windows, questi installa i driver ma poi se vado su gestione periferiche di win mi dice: “impossibile avviare la periferica (errore 10)” e ci mette il punto esclamativo. Ho provato ad aggiungere la riga in fstab ma non ho risolto il problema.
    Flavio, il 4 ott 2007 ha scritto:

    Ciao!! Ho risolto il problema ora funziona tutto!! Colpa mia, che usavo VirtualBox da Root, mentre fstab veniva caricato dall’utente principale..insomma un po un casino però ho aggiunto il mio nome nel gruppo vboxusers, ho reinstallato tutto e adesso le usb vanno alla grande!!!

    siccome anch’io accedo a linux come root, come faccio a controllare quello che hai fatto tu?

  43. Simone
    maggio 17, 2008 alle 3:15 pm

    Salve! Bel blog! Ho un piccolo quesito Per Virtualbox.
    Ho la Fedora 8 come host sulla mia linuxbox e sto cercando di virtualizzare Windows XP sulla mia Virtualbox 1.6.
    Tutto va per il liscio ma….. quando vado per fargli vedere i miei dischi usb in Windows XP non me li vede anche se nella mia vbox è settato il supporto. Dove sbaglio?

  44. Alessandro
    luglio 7, 2008 alle 4:08 pm

    Ciao a tutti.
    Chiedo soccorso per il seguente problema e ringrazio comunque in anticipo.
    Ho installato VirtualBox 1.5.6 sotto Vista. Usando VirtualBox ho installato una macchina guest Xp professional, nella schermata principale della quale, sotto dispositivi\ dispositivi usb `vedo` la mia pen drive usb ma, in Risorse del computer non appare nulla.
    Se vado, ripeto, nella finestra di Xp, dispositivi, dispositivi usb, leggo `Kingston Data Traveler 2.2 [0110]: Stato Catturato…
    Grazie.

  45. Danny Boy
    gennaio 23, 2009 alle 8:13 pm

    Sei un MITOOOOOOOOOOOO!
    Nel tuo blog ho trovato tutte le soluzioni possibili ai miei continui problemi con Linux, dal Naviga 3 + Motorola E770 a questa.
    Sei bravissimo, gente come te fa VERAMENTE venire voglia di passare a Linux e a non scoraggiarsi davanti alla difficoltà.
    I tuoi post mi danno il coraggio che mi serve per restare (e ne vado fiero) in Linux.
    GRAZIE!

  46. gennaio 23, 2009 alle 9:08 pm

    @Danny
    Che dire…sono senza parole… grazie!

  47. Rescorpione
    marzo 5, 2009 alle 7:50 pm

    Salve a tutti,
    mi sono appena imbattuto in questo problema, ho eseguito per benino i comandi di cui sopra ma la macchina virtuale XP, nella gestione risorse nessuna traccia della chiavetta USB.
    Ricapitolando : UBUNTU 8.10 e VIRTUALBOX 2.1.4 e XP dentro.
    Nelle impostazioni della VIRTUALBOX vedo 1 dispositivo e la chiavetta è montata in UBUNTU prima di avviare la macchina virtuale.
    Cosa posso provare ?
    grazie ciao

  48. jacky
    settembre 9, 2009 alle 10:00 pm

    io ho due chiavette usb vodafon e timnon compatibili tra loro. èstato applicato un potenziamento del softwer vodafon .quindi ora non mi funziona la chiavetta tim. come si può risolvere questo problema?

  49. marco
    novembre 11, 2009 alle 4:35 pm

    Ciao ragazzi ho un problema:
    host VISTA HOME Basic , guest win xp pro e ubuntu 9, mi riconosce le USB ma non me le fà usare, dice che è già attiva da un’altra parte.
    qualcuno può aiutarmi???
    grazie in anticipo.

  50. ricky
    novembre 29, 2009 alle 1:19 am

    Daniele, purtroppo non mi funziona.
    io ho ubuntu 9.04 e virtual box 2.1.4 ose
    ho scritto su terminale le istruzione e poi sono entrato in virtual box ed ho fatto partire windows xp, inserito la chiavetta ma i file li visualizza su ubuntu e ma non su windows!

    aiuto grazie, e buona serata!

    Ricky

  51. ricky
    novembre 29, 2009 alle 1:20 am

    Daniele, purtroppo non mi funziona.
    io ho ubuntu 9.04 e virtual box 2.1.4 ose
    ho scritto su terminale le istruzione e poi sono entrato in virtual box ed ho fatto partire windows xp, inserito la chiavetta ma i file li visualizza su ubuntu e ma non su windows!

    aiuto grazie, e buona serata!

    Ricky

  52. Enrico
    febbraio 2, 2010 alle 4:18 pm

    Ricky, nella OSE non c’è il supporto USB, devi installare la Full

  53. Gaetano
    febbraio 3, 2010 alle 10:41 pm

    Ciao a tutti.
    Vedo che i problemi di Virtualbox con le USB sono davvero tanti.
    Ci aggiungo il mio.
    Virtualbox 3.1.2 di Sun, con supporto USB gira su Ubuntu 9.10.
    Dentro Virtualbox ho installato Windows XP Pro SP2.
    Nelle impostazioni della macchina sono abilitati i controller USB e tutti i filtri dei dispositivi che ho.
    Una volta lanciato Virtualbox, se chiedo di collegare un dispositivo il sistema lo vede insieme a tutti gli altri, ma non sono cliccabili (sono in grigio)
    Qualcuno sa darmi una aiuto?
    Grazie

  54. alessio
    febbraio 4, 2010 alle 8:05 pm

    ciao a tutti ho lo stesso problema di gaetano chi mi puo aiutare?

  55. Gaetano
    febbraio 5, 2010 alle 1:55 am

    Per Alessio
    Premetto che non sono un esperto e parlo solo per esperienza, senza capire bene il perchè di certi comportamenti.
    Ho deselezionato dalla macchina virtuale tutti i filtri, lasciando attivato il supporto USB ed USB 2.0. La finestra dei filtri risulta vuota.
    Avviando la macchina, Virtualbox vede comunque tutte le USB e le rende tutte cliccabili tranne una stampante SAMSUNG che dice che non è supportata (e questo ci può anche stare). Devo però lasciare divattivati tastiera e mouse (entrambi USB), perchè altrimenti vanno in conflitto con UBUNTU e si bloccano entrambi. Pensandoci bene, se li fai gestire da Virtualbox il sistema HOST resterebbe senza periferiche di input. Comunque UBUNTU li gestisce anche dentro Virtualbox e funzionano lo stesso. Se risolvi in altro modo fammi sapere.
    Ciao

  56. alessio
    febbraio 5, 2010 alle 10:38 am

    ieri non so come, ho riavviato tutto è inserito le periferiche usb dopo aver avviato la macchina virtuale e ora le vede ….mah
    in pratica avevo problemi a far riconoscere delle chiavi hardware.

  57. alessio
    febbraio 5, 2010 alle 12:44 pm

    ma piu macchine virtuali possono vedere le stesse periferiche?
    io non ci sono ancora riuscito

  58. Gaetano
    febbraio 5, 2010 alle 1:04 pm

    Io non ci ho mai provato.
    In teoria direi di si, ma non contemporaneamente.
    E’ Virtualbox che riconosce le periferiche dell’host e monta i driver quando ancora non hai avviato nessuna macchina.
    Poi, quando hai avviato una delle macchine, decidi se collegarle a quella macchina oppure no.
    Se avvii più macchine contemporaneamente dovresti scollegare la periferica da una macchina prima di colegarla all’altra.
    D’altronde funziona così anche tra macchina virtuale e host.

  59. alessio
    febbraio 5, 2010 alle 1:10 pm

    ok grazie!

  60. claudio
    marzo 23, 2011 alle 2:49 pm

    ho fatto come dici. sono riuscito ad attivare usb della stampante, ma non la usb penna drive

  61. dante
    aprile 24, 2011 alle 12:32 pm

    Acc… ti ringrazio per i tuoi preziosissimi consigli ma a me non ha funzionato (uso Ubuntu da dieci giorni ….). Ho digitato alla lettera quello che mi hai indicato

    sudo gedit /etc/fstab
    none /proc/bus/usb usbfs devgid=46,devmode=664 0 0
    sudo mount -a

    come risposta mi da la seguente indicazione:

    mount: il mount point /proc/bus/usb non esiste

    puoi dirmi eventualmente dove ho sbagliato?
    devo fare qualche altra operazione?
    Inutile farti gl’auguri di Pasqua e riempirti di ringraziamenti… sono sentiti e sottointesi !!!!!
    Grazxie Dante

  62. dante
    aprile 24, 2011 alle 2:24 pm

    troppo impulsivo… le indicazioni che mi hai dato…. HANNO FUNZIONATO !!! (SCUSA LA RIMA ma grazie per l’indicazione)
    ciao Dante

  63. zorrito
    ottobre 29, 2011 alle 6:48 pm

    la versione ose non supporta l’usb

  64. gio
    gennaio 16, 2012 alle 1:39 am

    Ciao daniele. Io installato virtualbox sul mio mac per utilizzare win7.
    Ho cercato di utilizzare una penna usb ma al momento dell’installazione del driver
    mi dice che non è possibile e che c’è un problema. Mi potresti aiutare………?

  65. settembre 19, 2012 alle 6:30 pm

    Thank you for sharing superb informations. Your website is very cool.
    I am impressed by the details that you have on this website.
    It reveals how nicely you understand this subject.

    Bookmarked this website page, will come back for extra articles.
    You, my friend, ROCK! I found just the info I already
    searched everywhere and just could not come across. What a great web site.

  66. settembre 30, 2012 alle 11:40 pm

    I relish, cause I found just what I used to be taking a look
    for. You’ve ended my four day long hunt! God Bless you man. Have a great day. Bye

  67. ottobre 10, 2012 alle 10:28 pm

    I know of the fact that these days, more and more people will be attracted to cameras and the area of images.
    However, really being a photographer, you will need to first commit so much time period deciding which model of camera to
    buy along with moving out of store to store just so you can buy the cheapest camera of
    the trademark you have decided to settle on.
    But it doesn’t end now there. You also have to contemplate whether you should obtain a digital digicam extended warranty. Thanks alot : ) for the good recommendations I acquired from your blog.

  1. ottobre 16, 2007 alle 9:39 am
  2. ottobre 29, 2007 alle 6:10 pm
  3. novembre 19, 2007 alle 11:10 am
  4. gennaio 31, 2008 alle 11:26 pm
  5. ottobre 7, 2009 alle 6:38 pm
I commenti sono chiusi.
%d blogger cliccano Mi Piace per questo: