Home > Gibbon, Gutsy, Linux, tips & trick > Tips & Trick – Se VLC fa i capricci con il gibbone

Tips & Trick – Se VLC fa i capricci con il gibbone

ottobre 19, 2007

Primo giorno di Gibbon e già mi trovo alle prese con i primi problemucci.

Ora non sò se dipenda dal fatto che ho fatto un aggiornamento dalla feisty e avevo tante porcherie installate🙂 oppure da un vero e proprio bug in vlc o qualche libreria connessa ma, se provo ad avviare vlc, questo utilissimo software, si chiude miseramente.

Leggendo qua e là ho trovato la soluzione (almeno temporanea) per risolvere tale inconveniente.

Se anche voi riscontrate problemi nel lanciare vlc provate ad aprire il terminale e lanciate il comando:

G_SLICE=always-malloc vlc

Per me ha risolto.

Questo strano comando, imposta la variabile d’ambiente G_SLICE al valore always-malloc e poi lancia il comando vlc.

Se non volete ogni volta aprire vlc da terminale, potete inserire nel file /etc/environments G_SLICE=always-malloc e al prossimo reboot vlc dovrebbe funzionare sempre (anche se non sò se questa impostazione possa avere altri effetti collaterali su altri programmi).

Se scopro qualcosa di più su questo bug vi farò sapere…

Alla prossima

Daniele

  1. JD
    ottobre 19, 2007 alle 6:50 pm

    Ciao Daniele, anche io ho riscontrato lo stesso problema con VLC dopo aver aggiornato da Feisty a Gusty. Grazie 1000 per la dritta, appena posso la provo.
    Se si trova una soluzione più “pulita” facci sapere😉

  2. vincenzo
    ottobre 21, 2007 alle 9:18 am

    con gibbon ex novo (no update) tutto ok con vlc

  3. ottobre 21, 2007 alle 1:44 pm

    Grazie per la segnalzione Vincenzo..meno male!

  4. z
    gennaio 16, 2008 alle 10:16 am

    Grazieeeeeeeeeeeeeeeeeeeeeeeeeeeee

    il problema non era quello, precisamente il problema era che dopo aver modificato la skin di vlc, aprendo vlc non mi faceva + entrare nelle proprietà, anzi, di +, se provavo ad entrare nelle proprietà mi bloccava proprio il sistema costringendomi al riavvio da BOTTONE…….

    con il comando da te descritto invece si è aperto con già la finestra delle proprietà aperta, ho reimpostato la skin classica e adesso va una meraviglia……

    ciao e grazie ancora, erano già due gg che ci sbattevo, nemmeno disinstallando e reinstallando avevo risolto….

  1. No trackbacks yet.
I commenti sono chiusi.
%d blogger cliccano Mi Piace per questo: